American Eagles Modding Forums


Hi! You are currently viewing forum as a guest. For more features please login or register!

Member Login



Lost your password?

Forum Stats

Latest Member


Not a member yet? Sign Up!



*



February 24, 2020, 12:19:57 AM

Author Topic: combine attacher problems  (Read 96 times)

0 Members and 1 Guest are viewing this topic.

Offline jm44807 (OP)

combine attacher problems
« on: February 14, 2020, 03:52:52 PM »
im trying to convert a combine but i cant get header to line up on feeder house. i have tried setting it up by like 3 different combine but get same result. it seems like adjusting jointPositionOffset="0 0 -1.698" is the way to do it but i have tried different numbers but it does not work correctly. it moves it out to end of feederhouse but not up.

i have change every setting in attacher joints and redone all the nodes several times nothing has worked.
i changed attacher joint up and down doesnt seem to work right. i can get it to tip back more but not move up correctly.

been messing with this for 3 days so any help would be appreciated.

Code: [Select]
    <attacherJoints>
        <attacherJoint node="0>9|0|0" jointType="cutter"  jointPositionOffset="0 0 -1.698" lowerRotLimit="0 0 15" lowerTransLimit="0 0 0" lockDownRotLimit="true" moveTime="2.5" comboTime="0">
            <distanceToGround lower="1.13" upper="2.03" />
            <rotationNode node="0>9|0" lowerRotation="21 0 0" upperRotation="-10 0 0" />
            <bottomArm rotationNode="0>9|1" referenceNode="0>9|0|1" startRotation="0 0 0"/>
            <schema position="1 0" rotation="0" invertX="true" />
            <attachSound template="HEADER_ATTACH_01" linkNode="0>9|0|0" />
        </attacherJoint>
        <attacherJoint node="0>14" jointType="trailer" lowerRotLimit="10 70 50" upperRotationOffset="0" allowsJointLimitMovement="false" canTurnOnImplement="false" comboTime="1">
            <schema position="1 0" rotation="0" invertX="false"/>
            <attachSound template="ATTACH_01" linkNode="0>14" />
        </attacherJoint>
        <sounds>
            <hydraulic template="DEFAULT_HYDRAULIC_SOUND" linkNode="0>9|1|2" />
        </sounds>
    </attacherJoints>
 

Offline westmorgan

Re: combine attacher problems
« Reply #1 on: February 17, 2020, 11:14:59 PM »
I don't know what jointPositionOffset does. I played with it in game on a mod combine and couldn't see any change. I suspect that the attacherJoint position in the header i3d may be your culprit since those headers were not made specifically for that combine.
 

Offline jm44807 (OP)

Re: combine attacher problems
« Reply #2 on: February 21, 2020, 02:31:32 PM »
well got it to work by putting feederhouse in separate transfrom group  then rotated it. for some reason it worked fine until i put <bottomArm rotationNode="0>11|1" referenceNode="0>11|1|4" startRotation="0 0 0"/> this line in but without it the cylinders didnt work. seems like a workaround but it works
 
The following users thanked this post: JohnDeere1952

Offline JohnDeere1952

  • Administrator
  • ScreaminEagle
  • *
  • Posts: 3553
  • Thanked: 151 times
  • Search the Book of the Lord . . . Isaiah 34:16 (
Re: combine attacher problems
« Reply #3 on: February 21, 2020, 05:56:00 PM »
well got it to work by putting feederhouse in separate transfrom group  then rotated it. for some reason it worked fine until i put <bottomArm rotationNode="0>11|1" referenceNode="0>11|1|4" startRotation="0 0 0"/> this line in but without it the cylinders didnt work. seems like a workaround but it works
Thank you for sharing that fix.  (y)

Wait for the Lord; be strong and take heart and wait for the Lord. Psalm 27:14






 

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
1392 Views
Last post May 30, 2013, 07:25:00 PM
by AlbertL
0 Replies
736 Views
Last post November 23, 2013, 09:08:33 PM
by alexander escarraga
3 Replies
1750 Views
Last post April 21, 2014, 01:20:30 PM
by farmerboy71
1 Replies
1009 Views
Last post June 12, 2014, 05:38:42 PM
by jrd84
0 Replies
353 Views
Last post January 18, 2019, 09:32:06 PM
by farmerboi17

Powered by EzPortal